EDGE: System Requirement – OnPrem Installation

EDGE: System Requirement – OnPrem InstallationCategory: EDGE ConfigurationAuthor "Benjamin"EDGE: System Requirement – OnPrem Installation
Daniel Deutsch asked 4 months ago
Hello, I am interested in installing FORCE EDGE OnPrem. What are the system/server sizing (processor, memory etc.), OS and network requirements? What OS-options do exsists?
1 Answers
Benjamin Meißner Staff answered 4 months ago

Hello,
The system requirements depend on whether EDGE Configuration and Node are installed together on one system or whether they are installed on separate systems.
For the current version of EDGE the following requirements are necessary:

  • Windows 10 build 18362.1040 or newer, with WSL2 enabled
  • alternatively Windows Server 2019 version 1809 or newer, with WSL2 enabled
  • Docker Desktop version 3.6.0
  • AdoptOpenJDK 11 32 & 64 bit (32 bit only if the node is installed as a Windows service)

or

  • Ubuntu 20.04.3 LTS.
  • Docker Engine 20.10.8 or newer
  • Docker Compose version 1.29.2 or newer
  • OpenSSL version OpenSSL 1.1.0l or newer
  • OpenJDK 11 version 11.0.11 or newer

If both components are installed on one system, the following hardware is required:

  • Quadcore processor
  • Ram at least 16GB
  • free SSD memory at least 60GB

If EDGE Configuration and Node are installed on separate systems, the following hardware is required for each system:

  • Quadcore processor
  • Ram at least 8GB
  • free SSD memory at least 30GB